主机教程-解决Debian环境无法update更新源问题及更换阿里云镜像

无论我们是准备在VPS服务器中安装WEB环境,还是编译其他的软件功能,拿到VPS登录SSH之后我们肯定想到的先update环境这样可以确保服务器中的源是最新且还可以确保补丁最新。今天有在一台Debian环境中apt-get update更新源的时候有看到错误信息,而后肯定无法通过直接apt-get安装需要的软件(需要安装SQLITE)。

主机教程-解决Debian环境无法update更新源问题及更换阿里云镜像

从上图中可以看到源不通或者失效,所以才会有"E: Some index files failed to download, they have been ignored, or old ones used instead."的错误提示问题,那我们如何解决问题呢?

如果我们也是Debian环境,那就修改阿里云源,这样可以解决这个问题,当然还有其他源比如163等,我们用户不管了,谁好用老左就用哪个。

第一、替换文件

第二、替换源内容

我们将sources.list的内容全部替换成上面的阿里云源,然后再重新apt-get update -y之后可以完成更新。

主机教程-解决Debian环境无法update更新源问题及更换阿里云镜像

我们可以看到没有错误提示,那就说明解决问题了。

俊霖

发表评论

您必须