ECSHOP架设的php版本过高报错的解决方法集合

ECSHOP架设的php版本过高报错的解决方法集合

主要是php5.3以上版本会出现问题。

1.Strict standards: Non-static method cls_image::gd_version() should not be called statically in

2.Strict standards: Only variables should be passed by reference in

3.Strict Standards: Redefining already defined constructor for class alipay in

将所有的构造函数放到前面:

如alipay.php

放到

前面。

由于php5.3以上版本对函数的代码要求更加严格,所以导致ecshop的代码有了某些错误,更改以上错误就可以完美解决!

Have fun!

俊霖

发表评论

您必须

目前评论:1   其中:访客  1   博主  0

  1. 李春儿 5

    如果能给大家带来好处也不错。